Acer Chromebook 14 CB3-431 Sound

Briefly describe your issue below:
Has anyone had any luck in getting sound to work on the Acer Chromebook 14 via a live USB persistence? I managed to get the problematic display and trackpad to work, but I’ve spent a couple of days google-fu-ing the sound issues and nothing seems to work.

I tried patching with files from, but that didn’t work. Gallium OS works with the machine’s sound setup, I also have that running on a Live USB.

$aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: chtrt5650 [chtrt5650], device 0: Audio () []
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: chtrt5650 [chtrt5650], device 1: Deep-Buffer Audio (
) []
Subdevices: 1/1
Subdevice #0: subdevice #0

lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series High Definition Audio Controller (rev 35)

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)
Security 4.6 amd64
What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Live USB Standard
Configured to multiboot with other systems? (yes / no)
List your hardware specs to include make, model and firmware (when applicable):
Acer Chromebook 14 CB3-431
If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

UPDATE: installed firmware-intel-sound and the speakers are picked up.

In Sound Preferences>Hardware, “Built in Audio 1 Output/2 Inputs” shows, but there is still no sound with volume at max.

‘pulseaudio’ gives a couple of errors.

E: [pulseaudio] pid.c: Daemon already running.
E: [pulseaudio] main.c: pa_pid_file_create() failed.

Any ideas?

firecfg --fix-sound

Thanks for the reply, but I already tried that one and it didn’t help.

Try alsamixer. Run it by typing alsamixer in terminal. Your sound channel might be muted.

Did that too. It’s not muted (00 at the bottom). The card is PulseAudio, and it’s 100% volume, but there is no sound. If I switch the card to HDA Intel PCH, it displays S/PDIF, S/PDIF 1 and S/PDIF 2. I presume that’s for the HDMI output. Then there’s the chtrt5650 card which shows 100s of items that I have no idea about. Nothing in there seems to do anything.

Do you know the name of your audio card? If yes then check whether it is in the /proc/asound/cards file.
Run cat /proc/asound/cards in terminal.

Yeah, my card is chtrt5650 and it’s there in both the cards file and shows in alsamixer cards.

I just found that if I go into my sounds prefs, and switch the “Built-in Audio” prifike from Default to Off and back again, it lets out a banshee shriek and hisses.

adding pulseaudio --start --log-target=syslog to the startup applications might help. But I am not sure.

That didn’t work either. Looks like I’ll be at it a while longer. Oh, well, at least I’m learning as I go. :smiley: