AnonSurf not resetting to original

Briefly describe your issue below:

If I start AnonSurf it works perfectly. After I’m done using it, I click on “Stop AnonSurf”, but I get no internet connection. After I click “check IP”, the terminal opens, closes and I get a notification "My IP: " with the IP part empty.

What version of Parrot are you running? (include version, edition, and architecture)
4.1 SECURITY x86_64

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)

Debian standard

Configured to multiboot with other systems? (yes / no)
no, ParrotSec only
If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

Do you ever get back connectivity when bringing down and up the internet interface, restarting services, computer or user?

No, I don’t.

I must have AnonSurf enabled to be able to surf the internet.

anonsurf check get your ip from https://start.parrotsec.org/
so, if you cant reach the internet without tor, anonsurf wont show your ip

So do you have an internet connection before you start anonsurf and then it breaks when you stop it?
or
Do you only ever have an internet connection when you use anonsurf?

And are there any errors in the console like ‘file not found’ or anything?

at first, so, that was before I started AnonSurf for the first time, the internet was working. But after that, when I turned it off, it said that there was some problem with resetting IP and/or MAC, I was confused, so I restarted, which didn’t fix it. Now I have no internet connection unless I run AnonSurf start.

please send us the full error code or some screenshot

Can you connect to the lan? If yes, can you ping your gateway/router?

@g0rbe

When Anonsurf is stopped it doesn’t restore previous Parrot settings. Right now I get errors when not connected such as Name or service not known via terminal.

I need to restore everything back before running anonsurf for the first time. Did the dns settings get changed? What else could have changed and how to restore everything back?

Thank you!

And I also don’t have internet connection unless I’m running anonsurf. I think also some changes happened with IPV6 settings that were never restored.

Like iptables and ipv6 ?

Yes, anonsurf change it to 127.0.0.1 , 139.99.96.146 , 37.59.40.15 , 185.121.177.177

Iptables, restore:

iptables -F
iptables -t nat -F

resolv.conf, restore:

rm /etc/resolv.conf
mv /etc/resolv.conf.bak /etc/resolv.conf

disable ipv6, restore:

sysctl -w net.ipv6.conf.all.disable_ipv6=0
sysctl -w net.ipv6.conf.default.disable_ipv6=0

If you can start anonsurf without error, i cant understand what you did to fail the stop.
If you have furher problem, please send me a screenshot of the anonsurf start and anonsurf stop

@g0rbe

Thanks for your reply!

I did the steps as instructed.
I’m still experiencing the issue. I looked at the resolv.conf file, it seems that the IPV6 address there is incomplete.

I have compared with another computer with Parrot where I never ran anonsurf I see a more complete address in the resolv.conf file.

I’m got internet now after I restarted the computer, but it behaves weird. When I’m connected to a network that uses a proxy, it fails to work. I can’t even ping. ping: www.google.com: Temporary failure in name resolution.

There seems to be other things that were modified and not restored.

When running anonsurf stop, I didn’t see issues in the log.

Is there a way to restore all settings as if I installed Parrot for the first time? I have ran into the same issue before and was only resolved after reinstalling the OS. I really don’t won’t to do that because I have already installed many applications, Nvidia driver, etc…

ipv6 ??

What did you do with your resolv.conf ?
The anonsurf script impossible to add /try to add ipv6 nameserver to it.

Restore:

sudo iptables -F
sudo iptables -t nat -F
sudo sysctl -w net.ipv6.conf.all.disable_ipv6=0
sudo sysctl -w net.ipv6.conf.default.disable_ipv6=0
dpkg-reconfigure resolvconf

then reboot

Is this okay?

└──╼ $sudo resolvconf -u
/etc/resolvconf/update.d/libc: Warning: /etc/resolv.conf is not a symbolic link to /etc/resolvconf/run/resolv.conf

This is a directory.

└──╼ $ls -F | grep “resolv”
resolvconf/
resolv.conf@
resolv.conf.head

my fault, sorry, i am just just copied from the ( i am at work )

do this:

dpkg-reconfigure resolvconf

this will work (tested) :slight_smile:

2 Likes

Thank you so much I think we are narrowing down on the issue.

This gave me is not a symbolic link to /etc/resolvconf/run/resolv.conf
I rebooted but it didn’t work.

I went into another laptop and copied from there the resolv.conf info.
I create a new resolv.conf file
I added the domain address
also the two nameserver address

Cheers, I got internet in the network with the proxy where I had issues. I was able to connect and browser any website. I was also able to ping.

Now, the issue is when I switched to an external open network, I have no connection. Therefore DNS configuration don’t automatically update correctly when i switched networks.

I will try this dpkg-reconfigure resolvconf and reboot and let you know.

Thank you!

1 Like

Thank you so much that solved the issue. I can switch between networks and all connections work fine. You have no idea how happy I’m.

1 Like

I was having the same issue as ConnectionistSystems and this also worked for me, thanks!

Yes, @g0rbe did an awesome job to help me fix my problem.:smiley:

I have the exact same problem with you guys here when i stopped anonsurf, and this helped me… i can’t thank you enough :blush:

1 Like

Hi @ all,

I’m sorry but I’m new to Parrot and I run in the same issue like the other guys. If I stop Anonsurf by ‘anonsurf stop’ a damaged resolv.conf remains on the system. Copying the .bak-file or using dpkg-reconfigure solves the problem, but shouldn’t the script work without this ‘tricks’? Just start anonsurf, browse the web, stop anonsurf and continue surfing?

regards