Display sleeps dispite set to never

I’m running Parrot 4.7 (Security version, latest dist-upgrades installed. uname -r: 5.2.0-2parrot1-amd64) on a Lenovo S431 laptop.

My issue is that I’ve set the Power Management Preferences to never put the display to sleep or to dim. But after a few minutes of disuse, the display goes black. Doesn’t matter if it’s connected to AC or on battery. There are no settings in the bios for display power management.

Any suggestions for stopping the display from sleeping appreciated!

SOLVED!

In case anyone else has this issue, the solution (for me) was fairly simple:

sudo nano /etc/lightdm/lightdm.conf

(Note: you can replace nano with the text editor of your preference)

Scroll down to the section [Seat:*] and find the line that reads:

#xserver-command=X

and change it to:

xserver-command=X -s 0 dpms

(remove the leading # and add -s 0 dpms to the end)

Save the file and reboot. Problem solved.

2 Likes