Hak5 firmware update

if you have device from hak5 like me, do not upgrade to the latest firmware!!
they all have bugs … many bugs!

lanturtle (firmware v6) - module autossh not working (maybe more modules not working)
pineapple nano (firmware 2.6.0) - format sd card doesnt work, modules are half installed, etc …etc

i will wait before i update my pineapple tetra and Packet Squirrel cause they are in use
bashbunny firmware works for me

2 Likes

could you please give us the exact version of the affected firmware? maybe things would go better in the future, and having the exact affected versions would be helpful both for us and for the hak5 team

1 Like

firmware versions added!
exactly descriptions of the errors you will find in the hak5 forum. :wink:
this was only a post to maybe break the ice for others to start posting in this section. :wink:

1 Like

Pineappele Nano - Firmware 2.6.1 solves for me the problem with the sd-card. Only some modules (nmap, papers) make problems. maybe the module devs need more time to fix dependencies.

Pineapple Tetra - upgrade to 2.6.1 without problems. Same problem with some modules.

Packet Squirrl - upgrade to 3.1 without problems (openvpn module works … nothing other tested atm.)

stay tuned! :slight_smile: