Kernel 5.2 and RTL8822BE

Briefly describe your issue below:

WIFI Stopped working on Kernel 5.2 upgrade

What version of Parrot are you running? 4.7 AMD/KDE

What method did you use to install Parrot? Debian Standard

Configured to multiboot with other systems? No

If there are any similar issues or solutions, link to them below:

Don’t thnk so…

If there are any error messages or relevant logs, post them below:

Nope - wifi driver not loading…

Hi All

Since upgrading to kernel 5.2 (parrot-upgrade method) then the onboard wireless card of my laptop (HP Envy - Ryzen 2500) has stopped working

The card is a Realtek 8822BE and was working perfectly well under the 4.19 Kernel (in fact rebooting back into 4.19 makes it work)

Going through the usual triage process of lsmod type stuff and the R8822BE driver isn’t loaded so I took a look under /lib/modules/5.2.0 etc and it’s not present there (so I can’t modprobe it either)

Any ideas what’s up?

Thanks!!

me and @hotwater have worked on a patch in these days. try to upgrade the system to retry the new rtl88xxac driver

Thanks - will do… on last check I didn;t have any pending updates but will try again… speedy response much appreciated !!!

Hi

Apologies this took a little time…

Hope I’m not missing something (sorry if I am), but when I run ‘parrot-upgrade’ then I don’t get an updated rtl88xxac driver offered to me… In fact everything is up to date…

So, I ran ‘apt search rtl88’ and get 2 packages back as being installed and current:

apt search rtl88
Sorting… Done
Full Text Search… Done
firmware-realtek/rolling,rolling,now 20190717-1 all [installed]
Binary firmware for Realtek wired/wifi/BT adapters
realtek-rtl88xxau-dkms/rolling,rolling,now 5.6.1-1parrot1 all [installed,automatic]
Realtek RTL88xxAU driver in DKMS format

Have re-installed them anyway (with no issues) but the problem still remains :frowning:

Am I missing something? Thanks

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.

Looks like you have a relatively new card and general driver doesn’t work for you. There is a rtl_next repo on a github with drivers for your card, and we might package it, I have to discuss it with @palinuro.

Can you try reinstalling kernel 5.2? It looks like they still have your card support on board.

sudo apt reinstall linux-image-5.2.0-2parrot1-amd64

Hi

Kernel 5.2 reinstalled and sorry to report that the card still doesn’t work :slightly_frowning_face:

Logfile from reinstall:

kernel-reinstall.log (1.9 KB)

The weird thing is that it’s perfectly fine under 4.19.x I think that realtek have introduced some new driver code (merged into the 5.2 tree)?? maybe this has something to do with it?

Happy to build the driver if it’ll help… is this the GIT repo?

If so then the code is 2 years old - so not too sure it’ll help?

Sorry found the right repo now!!

Can you try removing realtek-rtl88xxau-dkms package and try booting to 4.19.xx kernel and see if the wifi works, and if it’s still working try removing firmware-realtek
We are trying to understand if it is a kernel problem or a package problem.
Thank’s for the assistance.

Sure…

Removed the dkms

remove-realtek-rtl88xxau-dkms.log (1.4 KB)

rebooted into 4.19 and eveything still worked…

post-remove-dkms.log (1.1 KB)

then I removed the realtek-firmware package…

remove-realtek-firmware.log (724 Bytes)

Now realtek related nothing works !!! In 4.19 anyway… will reboot back into into 5.2 and check it in a minute (and update this post…)

5.2 not working as well…

Re-installed the firmware-realtek package and 4.19 working again, 5.2 still not working…

Ok so it look’s like a bug in firmware-realtek. We will check it out.

Thanks and yes it does… having done a little research myself whilst trying to figure it out, came across this post:

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=931665

and less relevant (but similar):

https://bugzilla.redhat.com/show_bug.cgi?id=1738859

So it looks like there’s something funky going on with the 8822BE cards at the moment…

Please let me know if I can pull any diagnostics for you and thanks for the help so far!!!

1 Like

Also… whlst I was looking at this again, built the brivers from Larry Finger’s (?) rtlwifi_new git repo

Build_Output.log (13.6 KB)

Looks like it built OK - but didn’t make a difference either…

Update:

Further investigation, looks like the device does claim a differnt driver:

02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8822BE 802.11a/b/g/n/ac WiFi adapter
DeviceName: Realtek RTL8822BE 802.11 ac 2x2 WiFi + BT 4.2 Combo Adapter (MU-MIMO supported)
Subsystem: Hewlett-Packard Company RTL8822BE 802.11a/b/g/n/ac WiFi adapter
Flags: fast devsel, IRQ 10
I/O ports at f000 [disabled] [size=256]
Memory at fcf00000 (64-bit, non-prefetchable) [disabled] [size=64K]
Capabilities: [40] Power Management version 3
Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit+
Capabilities: [70] Express Endpoint, MSI 00
Capabilities: [100] Advanced Error Reporting
Capabilities: [148] Device Serial Number 00-e0-4c-ff-fe-b8-22-01
Capabilities: [158] Latency Tolerance Reporting
Capabilities: [160] L1 PM Substates
Kernel modules: wl

But the card doesn’t activate… also can now modprobe the rtlwifi (new??) driver:

rtlwifi 114688 0
btrtl 20480 1 btusb
bluetooth 655360 41 btrtl,btintel,btbcm,bnep,btusb,rfcomm
mac80211 864256 2 ath9k_htc,rtlwifi
cfg80211 819200 6 ath9k_htc,wl,ath9k_common,rtlwifi,ath,mac80211

But still not working properly… Looks like hings are different now??

1 Like

Thank’s for your help, from https://bugzilla.redhat.com/show_bug.cgi?id=1738859 we can see that it is an issue,

https://patchwork.kernel.org/patch/11065631/ patch confirmed, will be included in a new parrot kernel =).

Awesome!!! thanks guys :smile:

I have the same problem now it works on 4.7 but only through connecting on a hidden network
and it doesn’t even get recognized on 5. version

Hi Guys

I’m not sure if you where expecting it - but this issue isn’t fixed with the latest kernel upgrade:

Linux parrot 5.2.0-2parrot1-amd64 #1 SMP Debian 5.2.9-2parrot1 (2019-08-25) x86_64 GNU/Linux

Will keep testing and updating this post

Yes the same problem is still exist wifi works on the older kernel version but it doesn’t work on 5.2