No internet but connected to wifi

Briefly describe your issue below:
I’m connected to my home network wifi but it wont let me access the internet

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)
Parrot security os 4.7

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Standard installation
Configured to multiboot with other systems? (yes / no)
No
List your hardware specs to include make, model and firmware (when applicable):
I installed it on toshiba tecra c50-c
If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

Hello @dopeguy71313 :slightly_smiling_face:

Few questions.

  1. Can you access internet on other devices connected to same network?
  2. Type the following command in terminal & share the output of pluma /etc/resolv.conf
  3. What error do you get when you try to connect to the internet via firefox or ping something. These should be some sort of error message or error code. Any sort of error logs would be helpful too.

Let us know how it goes :blush:

It often happens DNS in linux is set to 127.0.0.1. Follow these steps to fix connection:

  1. open Terminal
  2. sudo vim /etc/resolv.conf
  3. open the editor with choosing E(dit anyway)
  4. clean the line that says “nameserver 127.0.0.1”
  5. write in the first line: nameserver 8.8.8.8
  6. write in the second line: nameserver 8.8.4.4
  7. hit Esc to enter normal mode and type :wq
  8. Done! Now restart your computer and try again.

Additionally, Have a look at this

make sure your system time/date are set properly