Printer service not available

Briefly describe your issue below:
I have to restart the CUPS service from the command line each time I boot, to be able to access printers. How can I configure this service to start automatically?

If I try to restart the service via menus “System - Administration - Printer Settings” and then “Start Service” it doesn’t seem to work…
But it works with the command “sudo /etc/init.d/cups restart”

It seems that it is not recommended to put this command in rc.local …
What is the best way to get the CUPS service started without human intervention?

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)
Release 4.7 64-bit
Kernel Linux 5.2.0-2parrot1-amd64 x86_64
MATE 1.22.1

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Debian Standard

Configured to multiboot with other systems? (yes / no)
Yes

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

1 Like

Try this:

sudo systemctl enable cups.service && sudo systemctl start cups.service

“systemctl enable” will enable the cups.service at boot, and “systemctl start” will start it right away.

After running the first command, the second command should no longer be necesary. Personally, I try to lock down any port I can, even if it’s just limited to localhost while I’m out in public. Maybe I’m paranoid though. :woman_shrugging:

2 Likes

Wonderful, it works!
About your personal opinion, well…, you are right, prevention is better than cure.
Many thanks for the support.

This worked for me too, but I also had to add a printer driver. I have a Brother printer and I used Synaptic and searched for “brlaser”.