Problem with Nvidia drivers installation

Hi I tried install Nvidia drivers from this link

but I got error after installation, Can someone help me to fix that I tried lots of command from google but it didn’t help.

dpkg --configure -a

Setting up nvidia-kernel-dkms (418.56-2) ...
Removing old nvidia-current-418.56 DKMS files...

Deleting module version: 418.56
completely from the DKMS tree.
Loading new nvidia-current-418.56 DKMS files...
Building for 5.1.0-parrot1-3t-amd64
Building initial module for 5.1.0-parrot1-3t-amd64
Error! Bad return status for module build on kernel: 5.1.0-parrot1-3t-amd64 (x86_64)
Consult /var/lib/dkms/nvidia-current/418.56/build/make.log for more information.
dpkg: error processing package nvidia-kernel-dkms (--configure):
 installed nvidia-kernel-dkms package post-installation script subprocess returned error exit status 10
dpkg: dependency problems prevent configuration of nvidia-driver:
 nvidia-driver depends on nvidia-kernel-dkms (= 418.56-2) | nvidia-kernel-418.56; however:
  Package nvidia-kernel-dkms is not configured yet.
  Package nvidia-kernel-418.56 is not installed.
  Package nvidia-kernel-dkms which provides nvidia-kernel-418.56 is not configured yet.

dpkg: error processing package nvidia-driver (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
└──╼ #

sudo apt-get update

sudo apt-get install nvidia-driver-418

If that returns no results go to the folder that has the Nvidia driver you downloaded. Run:



1 Like

This package doesn’t even exist if you check it with apt search nvidia-driver-418.
However, it was fixed lately, so just run

sudo parrot-upgrade
1 Like

I’ve run “sudo parrot-upgrade” and system was upgrade but when I try to verifity nvidia on my laptop via command “hashcat -I” I got
hashcat (v5.1.0) starting…

No devices found/left.

Is there any other way to install it or get it fixed? I would be so grateful for help.


Firstly, if you used our nvidia installation guide - you now have bumblebee controlling your card, so any package you want with NVIDIA gpu - run it with optirun [package_name].
In order for hashcat to see your card - you also have to run it from root, so try sudo optirun hashcat -i.

Which is why I used the words ”If that returns no results”.

Bumblebee is a piece of extra software, certainly not going to call it a good one, maybe a novelty at best. If you’re not worried about minute power savings and you want to use your graphics card without modifying the existing command structure you’ve already memorized, you’re going to have to install the driver the typical Debian way. The way that has worked for years. Download, configure, make-install.

You CAN do it with apt if you add the Ubuntu-universe repo… Update, install driver then go directly to sources and mark it out so it can’t be used anymore.

i have had similar issues with nvidia at times. I have a 1050ti, that i use to game, (yes, on ParrotSec, With Steam) I had tried various methods to install my card. ut this method seems to work about everytime:

Uninstall/Pruge/Autoremove/Autoclean nvidia from your system. (Cleans leftovers from os)
sudo su
apt update
parrot-upgrade - wait. Reboot.
As Root:
apt install nvidia-detect
if you run into issues with not finding the server issue this command:
apt install -f && apt install nvidia-detect
Results will display in terminal, the reccomended driver to install will be.

If you do not have your kernal header installed, do it first:
sudo apt install linux-headers-$(uname -r)
after that, issue:
sudo apt install nvidia-legacy-XXXxx-driver
(XXXxxx will be replaced with the driver reccomended by nvidia-detect)

This works for me every time, and i get good frame rate.
Hope this helps.

1 Like

I try to install apt-get GeForce MX150
and no command found:

‘‘apt install GeForce MX150’’

Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package GeForce
E: Unable to locate package MX150


Detected NVIDIA GPUs:
01:00.0 3D controller [0302]: NVIDIA Corporation GP108M [GeForce MX150] [10de:1d10] (rev ff)

Checking card: NVIDIA Corporation GP108M [GeForce MX150] (rev ff)
Uh oh. Failed to identify your Debian suite.

Can you help me please? Thank you.

please follow our guide and if you have problems, create another thread for it. docs