Problem with smbclient in Parrot 5.3.9-3parrot3

Hi All,

I am using Parrot MP Parrot 5.3.9-3parrot3 (2019-11-23) but have some issues using smbclient to login to shares in a remote machine.

Command used: $smbclient //metasploitable/tmp
Error : protocol negotiation failed: NT_STATUS_CONNECTION_DISCONNECTED

I have tried tried every suggestion from google but nothing works.

Your help will be highly appriciated.

Kind Regards,
PaulIn

hi,
maybe you have to set the -m option?
LINK

Hi,

I used the -m option like smbclient -m SMB2 //metasploitable/tmp and smbclient -m SMB3 //metasploitable/tmp but still get the same error

Paulin,

I was able to get to my shares using the mount.cifs utilities. If I remember right, SMB is being deprecated sometime in the near future with CIFS taking it’s place as flavor of choice. But I could be wrong about that.

You may have to install the CIFS utilities before the below command will work.

#sudo apt install cifs-utils

I had to specify they userid and groupid to ensure proper permissions were labeled at connection otherwise it defaults to root:root.

#mount.cifs //server/shared /mountpoint -o uid=USERID,gid=GROUPID

Also, I’ll have to check when I get home, but I may have had to add it to /etc/fstab file. I can’t quite remember now.

Hi Josh,

Thanks for the help.
I will give it a try and let you know.
Have a great day.

Yeah let me know if it works. It looks like I did add an entry in the fstab file.

//IP.Address/SharedFolder /MountPoint cifs rw,.smbcredentails, 0 1

.smbcredentials is a file with the username/password in it created in the root home directory. Then the 0 and 1 refer to the user and group id respectively if I’m not mistaken.