Problems installing bumblebee

I am new here.
Can’t seem to create a new topic…
Could someone please help me?
When I hover my mouse over the block, the pointer turns to a red circle with a line through it.

I would also like to know if there is a command I can use to check if all my hardware is compatible with Parrot?

Linux parrot 4.19.0-parrot2-28t-amd64 #1 SMP Parrot 4.19.28-2parrot2.28t (2019-04-08)
I used the Debian GTK - Graphics installer
not configured to mulitiboot

┌─[✗]─[subz@parrot]─[~]
└──╼ $optirun glxgears
Could not find the database of available applications, run update-command-not-found as root to fix this

Please include the following information with the report:

command-not-found version: 0.3
Python version: 3.7.3 candidate 1
Distributor ID: Parrot
Description: Parrot GNU/Linux 4.6
Release: 4.6
Codename: n/a
Exception information:

local variable ‘cnf’ referenced before assignment
Traceback (most recent call last):
File “/usr/share/command-not-found/CommandNotFound/util.py”, line 23, in crash_guard
callback()
File “/usr/lib/command-not-found”, line 93, in main
if not cnf.advise(args[0], options.ignore_installed) and not options.no_failure_msg:
UnboundLocalError: local variable ‘cnf’ referenced before assignment

after running the specified command sudo update-command-not-found
nothing changes.

┌─[subz@parrot]─[~]
└──╼ $sudo apt update && sudo apt install bumblebee primus
[sudo] password for subz:
Get:1 InRelease [14.6 kB]
Fetched 14.6 kB in 2s (6,404 B/s)
Reading package lists… Done
Building dependency tree
Reading state information… Done
All packages are up to date.
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following additional packages will be installed:
bbswitch-dkms libgl1-mesa-glx:i386 primus-libs primus-libs:i386
primus-libs-ia32:i386
Suggested packages:
bumblebee-nvidia nvidia-driver-libs-nonglvnd
| nvidia-legacy-390xx-driver-libs-nonglvnd
The following NEW packages will be installed:
bbswitch-dkms bumblebee libgl1-mesa-glx:i386 primus primus-libs
primus-libs:i386 primus-libs-ia32:i386
0 upgraded, 7 newly installed, 0 to remove and 0 not upgraded.
Need to get 229 kB of archives.
After this operation, 904 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
0~20150328-7 [3,996 B]
Fetched 229 kB in 8s (30.4 kB/s)
Selecting previously unselected package bbswitch-dkms.
(Reading database … 738177 files and directories currently installed.)
Preparing to unpack …/0-bbswitch-dkms_0.8-8_amd64.deb …
Unpacking bbswitch-dkms (0.8-8) …
Selecting previously unselected package bumblebee.
Preparing to unpack …/1-bumblebee_3.2.1-20_amd64.deb …
Unpacking bumblebee (3.2.1-20) …
Selecting previously unselected package libgl1-mesa-glx:i386.
Preparing to unpack …/2-libgl1-mesa-glx_18.3.4-2_i386.deb …
Unpacking libgl1-mesa-glx:i386 (18.3.4-2) …
Selecting previously unselected package primus-libs:amd64.
Preparing to unpack …/3-primus-libs_0~20150328-7_amd64.deb …
Unpacking primus-libs:amd64 (0~20150328-7) …
Selecting previously unselected package primus.
Preparing to unpack …/4-primus_0~20150328-7_amd64.deb …
Unpacking primus (0~20150328-7) …
Selecting previously unselected package primus-libs:i386.
Preparing to unpack …/5-primus-libs_0~20150328-7_i386.deb …
Unpacking primus-libs:i386 (0~20150328-7) …
Selecting previously unselected package primus-libs-ia32:i386.
Preparing to unpack …/6-primus-libs-ia32_0~20150328-7_i386.deb …
Unpacking primus-libs-ia32:i386 (0~20150328-7) …
Setting up primus-libs:amd64 (0~20150328-7) …
Setting up libgl1-mesa-glx:i386 (18.3.4-2) …
Setting up bbswitch-dkms (0.8-8) …
Loading new bbswitch-0.8 DKMS files…
Building for 4.19.0-parrot2-28t-amd64
Building initial module for 4.19.0-parrot2-28t-amd64
Done.

bbswitch.ko:
Running module version sanity check.

  • Original module
    • No original module exists within this kernel
  • Installation
    • Installing to /lib/modules/4.19.0-parrot2-28t-amd64/kernel/drivers/acpi/

depmod…

DKMS: install completed.
Setting up primus-libs:i386 (0~20150328-7) …
Setting up bumblebee (3.2.1-20) …
Adding members from group(s) ‘adm sudo admin’ to ‘bumblebee’:
subz
Adding user subz to group bumblebee
update-rc.d: We have no instructions for the bumblebeed init script.
update-rc.d: It looks like a non-network service, we enable it.
Created symlink /etc/systemd/system/graphical.target.wants/bumblebeed.service → /lib/systemd/system/bumblebeed.service.
Setting up primus-libs-ia32:i386 (0~20150328-7) …
Setting up primus (0~20150328-7) …
Processing triggers for systemd (241-3) …
Processing triggers for man-db (2.8.5-2) …
Processing triggers for initramfs-tools (0.133) …
update-initramfs: Generating /boot/initrd.img-4.19.0-parrot2-28t-amd64
Scanning processes…
Scanning processor microcode…
Scanning linux images…

Running kernel seems to be up-to-date.

The processor microcode seems to be up-to-date.

No services need to be restarted.

No containers need to be restarted.

No user sessions are running outdated binaries.
Configuring sandbox profiles…
Sandbox profiles updated!
┌─[subz@parrot]─[~]
└──╼ $optirun glxgears
[ 4886.008657] [ERROR]You’ve no permission to communicate with the Bumblebee daemon. Try adding yourself to the ‘bumblebee’ group
[ 4886.008752] [ERROR]Could not connect to bumblebee daemon - is it running?
┌─[✗]─[subz@parrot]─[~]
└──╼ $bumblebee daemon
Could not find the database of available applications, run update-command-not-found as root to fix this
Sorry, command-not-found has crashed! Please file a bug report at:
**
Please include the following information with the report:

command-not-found version: 0.3
Python version: 3.7.3 candidate 1
Distributor ID: Parrot
Description: Parrot GNU/Linux 4.6
Release: 4.6
Codename: n/a
Exception information:

local variable ‘cnf’ referenced before assignment
Traceback (most recent call last):
File “/usr/share/command-not-found/CommandNotFound/util.py”, line 23, in crash_guard
callback()
File “/usr/lib/command-not-found”, line 93, in main
if not cnf.advise(args[0], options.ignore_installed) and not options.no_failure_msg:
UnboundLocalError: local variable ‘cnf’ referenced before assignment
┌─[✗]─[subz@parrot]─[~]
└──╼ $sudo optirun glxgears
primus: fatal: failed to load any of the libraries: /usr/lib/x86_64-linux-gnu/nvidia/libGL.so.1:/usr/lib/i386-linux-gnu/nvidia/libGL.so.1:/usr/lib/nvidia/libGL.so.1
/usr/lib/x86_64-linux-gnu/nvidia/libGL.so.1: cannot open shared object file: No such file or directory
/usr/lib/i386-linux-gnu/nvidia/libGL.so.1: cannot open shared object file: No such file or directory
/usr/lib/nvidia/libGL.so.1: cannot open shared object file: No such file or directory
┌─[✗]─[subz@parrot]─[~]
└──╼ $

I’ve unlisted your post as it is not clear what you need help with. Do you need help with your graphic card or are you trying to figure out if your system meets the system requirements? To check system requirements please search for system requirements on our docs portal.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.