Solving the busybox error on 4.7

Hi everyone, recently parrot 4.7 came out and a lot of user face the same issue which is:

Here is a quick way of solving it without reinstalling the entire system:

1) Get a live usb of parrot or any debian distro and boot live.

2) Run this command:

sudo fdisk -l

fdisk will list all drive connected and partitions on them. On this list you have to find a few things:

  • your root partition called “/
  • a /boot partition if you have one

3) For the next set of commands, we will use sda1 as our /boot and sda2 as our / (root) partition.

sudo mount /dev/sda2 /mnt

To be sure that you mounted the correct partition you can run ls /mnt and if you see the standard content of a linux root directory (such as /dev, /bin, /home…) it means you did the preceding operations correctly.

sudo mount /dev/sda1 /mnt/boot

Ones again you can check the /mnt/boot content to be sure you did it correctly.

sudo mount --bind /dev /mnt/dev
sudo mount --bind /sys /mnt/sys
sudo mount --bind /proc /mnt/proc

4) Finally:

sudo chroot /mnt

update-initramfs -u

if update-initramfs ran successfully, you can now run:



And enjoy your parrot !


Fantastic! Worked for me on Parrot v4.7.1 beta - however nothing worked at all with v4.7 beta - thanks for info.

BTW - my encrpyted LUKS partitions did not work - but I will look into that … Not sure yet what that is about…

Parrot v4.7 is proving rather shoddy so far…let’s see …That’s two releases so far that didn’t even boot!

1 Like

ok - BUT I cannot get this to work with my /dev/sda5 LUKS encrypted LVM volumes … My older Parrot builds all have LUKS and prompt for passphrase during boot - not sure how to do with these instructions - as we have LVM volumes insiide of a LVM Volume Group, inside an enctpyed partition /dev/sda5

Anyone got any ideas how to make that work with busted Parrot v4.7 boot process ??!!

Good News! I can confirm that these steps above work with LUKS manual setup as well - BUT you need to do a couple of prelimanery steps first:

# find luks devices on system
blkid | grep crypto

# un-lock it - you will need passphrase
cryptsetup luksOpen /dev/sda5 sda5_crypt

Note: It is important that last parameter above matches what’s in your /etc/crypttab file on the harddisk (ie the real name of your encrpyted partition) - use blkid for that (but there’s a catch - you can only see once you already opened it :wink:

and then you can follow steps about - but mount /root from LUKS LVM mapper (presuming you encrypted /root):

# now it is opened - we can mount internal root volume
mount /dev/mapper/parrot-root /mnt

Just follow the rest of KileXt steps above - you shold be prompted for passphrase on next boot.

Remember - keep your disks encrypted and keep your data, build, keys, passwords, and life private!

Long live the Parrot!


Hi, i wanted to thank you for your contribution !

And as you said: Long live the Parrot !

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.