System Cant Enter Suspend Mode

Briefly describe your issue below:
When I try to suspend my desktop the screen and keyboard turns off but the desktop doesn’t enter suspend mode, the light stays blue and the fans are running, I have to hard reset to fix the issue. If I disconnect the wifi adapter (Realtek 8812BU) then the desktop is able to enter suspend mode. The adapter is USB 3.0 plugged into a 2.0 port (no 3.0 ports). From the logs I was only able to narrow down the issue to the adapter. I can’t figure out how to unbind the adapter before suspending and if that will fix the issue and to bind it again when it wakes up from suspend. Any help would be appreciated!

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)

Linux parrot 5.2.0-2parrot1-amd64 #1 SMP Debian 5.2.9-2parrot1 (2019-08-25) x86_64 GNU/Linux

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)

Debian GTK

Configured to multiboot with other systems? (yes / no)
Yes and no its on its own SSD and is first on the boot order BIOS

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:
syslog

Sep 13 13:15:53 parrot rtkit-daemon[1422]: Failed to look up client: No such file or directory
Sep 13 13:15:53 parrot rtkit-daemon[1422]: Supervising 2 threads of 1 processes of 1 users.
Sep 13 13:15:53 parrot rtkit-daemon[1422]: Failed to look up client: No such file or directory
Sep 13 13:15:54 parrot rtkit-daemon[1422]: Supervising 2 threads of 1 processes of 1 users.
Sep 13 13:15:54 parrot rtkit-daemon[1422]: Supervising 2 threads of 1 processes of 1 users.
Sep 13 13:15:54 parrot rtkit-daemon[1422]: Failed to look up client: No such file or directory
Sep 13 13:15:54 parrot rtkit-daemon[1422]: Supervising 2 threads of 1 processes of 1 users.
Sep 13 13:15:54 parrot rtkit-daemon[1422]: Supervising 2 threads of 1 processes of 1 users.
Sep 13 13:15:54 parrot rtkit-daemon[1422]: Failed to look up client: No such file or directory
Sep 13 13:15:54 parrot rtkit-daemon[1422]: Supervising 2 threads of 1 processes of 1 users.
Sep 13 13:15:54 parrot rtkit-daemon[1422]: Supervising 2 threads of 1 processes of 1 users.
Sep 13 13:15:54 parrot rtkit-daemon[1422]: Failed to look up client: No such file or directory
Sep 13 13:15:54 parrot rtkit-daemon[1422]: Supervising 2 threads of 1 processes of 1 users.
Sep 13 13:15:54 parrot rtkit-daemon[1422]: Supervising 2 threads of 1 processes of 1 users.
Sep 13 13:15:54 parrot rtkit-daemon[1422]: Failed to look up client: No such file or directory
Sep 13 13:16:02 parrot kernel: [  197.149684] RTW: rtw_set_ps_mode(wlan0) Enter 802.11 power save - WIFI-TRAFFIC_IDLE
Sep 13 13:16:02 parrot kernel: [  197.149689] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
Sep 13 13:16:02 parrot kernel: [  197.149692] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = LPS, drv ps mode = 2, rlbm = 1 , smart_ps = 2, allQueueUAPSD = 0
Sep 13 13:16:04 parrot kernel: [  199.165599] RTW: rtw_set_ps_mode(wlan0) Leave 802.11 power save - WIFI-TRAFFIC_BUSY
Sep 13 13:16:04 parrot kernel: [  199.165603] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
Sep 13 13:16:04 parrot kernel: [  199.165605] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = ACTIVE, drv ps mode = 0, rlbm = 0 , smart_ps = 0, allQueueUAPSD = 0
Sep 13 13:16:06 parrot kernel: [  201.181635] RTW: rtw_set_ps_mode(wlan0) Enter 802.11 power save - WIFI-TRAFFIC_IDLE
Sep 13 13:16:06 parrot kernel: [  201.181643] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
Sep 13 13:16:06 parrot kernel: [  201.181648] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = LPS, drv ps mode = 2, rlbm = 1 , smart_ps = 2, allQueueUAPSD = 0
Sep 13 13:16:14 parrot kernel: [  209.245632] RTW: rtw_set_ps_mode(wlan0) Leave 802.11 power save - WIFI-TRAFFIC_BUSY
Sep 13 13:16:14 parrot kernel: [  209.245640] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
Sep 13 13:16:14 parrot kernel: [  209.245646] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = ACTIVE, drv ps mode = 0, rlbm = 0 , smart_ps = 0, allQueueUAPSD = 0
Sep 13 13:16:16 parrot kernel: [  211.261656] RTW: rtw_set_ps_mode(wlan0) Enter 802.11 power save - WIFI-TRAFFIC_IDLE
Sep 13 13:16:16 parrot kernel: [  211.261668] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
Sep 13 13:16:16 parrot kernel: [  211.261673] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = LPS, drv ps mode = 2, rlbm = 1 , smart_ps = 2, allQueueUAPSD = 0
Sep 13 13:16:21 parrot rtkit-daemon[1422]: Supervising 2 threads of 1 processes of 1 users.
Sep 13 13:16:21 parrot rtkit-daemon[1422]: Supervising 2 threads of 1 processes of 1 users.
Sep 13 13:16:21 parrot rtkit-daemon[1422]: Failed to look up client: No such file or directory
Sep 13 13:16:21 parrot rtkit-daemon[1422]: Supervising 2 threads of 1 processes of 1 users.
Sep 13 13:16:21 parrot rtkit-daemon[1422]: Supervising 2 threads of 1 processes of 1 users.
Sep 13 13:16:21 parrot rtkit-daemon[1422]: Failed to look up client: No such file or directory
Sep 13 13:16:22 parrot kernel: [  217.309599] RTW: rtw_set_ps_mode(wlan0) Leave 802.11 power save - WIFI-TRAFFIC_BUSY
Sep 13 13:16:22 parrot kernel: [  217.309605] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
Sep 13 13:16:22 parrot kernel: [  217.309608] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = ACTIVE, drv ps mode = 0, rlbm = 0 , smart_ps = 0, allQueueUAPSD = 0
Sep 13 13:16:39 parrot kernel: [  233.437637] RTW: rtw_set_ps_mode(wlan0) Enter 802.11 power save - WIFI-TRAFFIC_IDLE
Sep 13 13:16:39 parrot kernel: [  233.437645] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
Sep 13 13:16:39 parrot kernel: [  233.437650] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = LPS, drv ps mode = 2, rlbm = 1 , smart_ps = 2, allQueueUAPSD = 0
Sep 13 13:16:45 parrot kernel: [  239.485639] RTW: rtw_set_ps_mode(wlan0) Leave 802.11 power save - WIFI-TRAFFIC_BUSY
Sep 13 13:16:45 parrot kernel: [  239.485646] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
Sep 13 13:16:45 parrot kernel: [  239.485650] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = ACTIVE, drv ps mode = 0, rlbm = 0 , smart_ps = 0, allQueueUAPSD = 0
Sep 13 13:16:47 parrot kernel: [  241.501640] RTW: rtw_set_ps_mode(wlan0) Enter 802.11 power save - WIFI-TRAFFIC_IDLE
Sep 13 13:16:47 parrot kernel: [  241.501646] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
Sep 13 13:16:47 parrot kernel: [  241.501651] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = LPS, drv ps mode = 2, rlbm = 1 , smart_ps = 2, allQueueUAPSD = 0
Sep 13 13:16:53 parrot kernel: [  247.549636] RTW: rtw_set_ps_mode(wlan0) Leave 802.11 power save - WIFI-TRAFFIC_BUSY
Sep 13 13:16:53 parrot kernel: [  247.549644] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
Sep 13 13:16:53 parrot kernel: [  247.549649] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = ACTIVE, drv ps mode = 0, rlbm = 0 , smart_ps = 0, allQueueUAPSD = 0
Sep 13 13:17:01 parrot CRON[2227]: (root) CMD (   cd / && run-parts --report /etc/cron.hourly)
Sep 13 13:17:01 parrot kernel: [  255.613636] RTW: rtw_set_ps_mode(wlan0) Enter 802.11 power save - WIFI-TRAFFIC_IDLE
Sep 13 13:17:01 parrot kernel: [  255.613644] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
Sep 13 13:17:01 parrot kernel: [  255.613650] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = LPS, drv ps mode = 2, rlbm = 1 , smart_ps = 2, allQueueUAPSD = 0
Sep 13 13:17:07 parrot kernel: [  261.661670] RTW: rtw_set_ps_mode(wlan0) Leave 802.11 power save - WIFI-TRAFFIC_BUSY
Sep 13 13:17:07 parrot kernel: [  261.661677] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
Sep 13 13:17:07 parrot kernel: [  261.661682] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = ACTIVE, drv ps mode = 0, rlbm = 0 , smart_ps = 0, allQueueUAPSD = 0
Sep 13 13:17:09 parrot kernel: [  263.677641] RTW: rtw_set_ps_mode(wlan0) Enter 802.11 power save - WIFI-TRAFFIC_IDLE
Sep 13 13:17:09 parrot kernel: [  263.677649] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
Sep 13 13:17:09 parrot kernel: [  263.677654] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = LPS, drv ps mode = 2, rlbm = 1 , smart_ps = 2, allQueueUAPSD = 0
Sep 13 13:17:17 parrot kernel: [  271.741634] RTW: rtw_set_ps_mode(wlan0) Leave 802.11 power save - WIFI-TRAFFIC_BUSY
Sep 13 13:17:17 parrot kernel: [  271.741641] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
Sep 13 13:17:17 parrot kernel: [  271.741647] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = ACTIVE, drv ps mode = 0, rlbm = 0 , smart_ps = 0, allQueueUAPSD = 0
Sep 13 13:17:19 parrot kernel: [  273.757601] RTW: rtw_set_ps_mode(wlan0) Enter 802.11 power save - WIFI-TRAFFIC_IDLE
Sep 13 13:17:19 parrot kernel: [  273.757607] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
Sep 13 13:17:19 parrot kernel: [  273.757610] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = LPS, drv ps mode = 2, rlbm = 1 , smart_ps = 2, allQueueUAPSD = 0
Sep 13 13:17:19 parrot rtkit-daemon[1422]: Supervising 2 threads of 1 processes of 1 users.
Sep 13 13:17:19 parrot rtkit-daemon[1422]: Supervising 2 threads of 1 processes of 1 users.
Sep 13 13:17:19 parrot rtkit-daemon[1422]: Failed to look up client: No such file or directory
Sep 13 13:17:19 parrot rtkit-daemon[1422]: Supervising 2 threads of 1 processes of 1 users.
Sep 13 13:17:19 parrot rtkit-daemon[1422]: Supervising 2 threads of 1 processes of 1 users.
Sep 13 13:17:19 parrot rtkit-daemon[1422]: Failed to look up client: No such file or directory
Sep 13 13:17:21 parrot kernel: [  275.773600] RTW: rtw_set_ps_mode(wlan0) Leave 802.11 power save - WIFI-TRAFFIC_BUSY
Sep 13 13:17:21 parrot kernel: [  275.773605] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
Sep 13 13:17:21 parrot kernel: [  275.773608] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = ACTIVE, drv ps mode = 0, rlbm = 0 , smart_ps = 0, allQueueUAPSD = 0
Sep 13 13:17:25 parrot kernel: [  279.805645] RTW: rtw_set_ps_mode(wlan0) Enter 802.11 power save - WIFI-TRAFFIC_IDLE
Sep 13 13:17:25 parrot kernel: [  279.805653] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
Sep 13 13:17:25 parrot kernel: [  279.805659] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = LPS, drv ps mode = 2, rlbm = 1 , smart_ps = 2, allQueueUAPSD = 0
Sep 13 13:17:27 parrot kernel: [  281.821597] RTW: rtw_set_ps_mode(wlan0) Leave 802.11 power save - WIFI-TRAFFIC_BUSY
Sep 13 13:17:27 parrot kernel: [  281.821604] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
Sep 13 13:17:27 parrot kernel: [  281.821607] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = ACTIVE, drv ps mode = 0, rlbm = 0 , smart_ps = 0, allQueueUAPSD = 0
Sep 13 13:17:29 parrot kernel: [  283.837643] RTW: rtw_set_ps_mode(wlan0) Enter 802.11 power save - WIFI-TRAFFIC_IDLE
Sep 13 13:17:29 parrot kernel: [  283.837647] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
Sep 13 13:17:29 parrot kernel: [  283.837649] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = LPS, drv ps mode = 2, rlbm = 1 , smart_ps = 2, allQueueUAPSD = 0
Sep 13 13:17:31 parrot kernel: [  285.853669] RTW: rtw_set_ps_mode(wlan0) Leave 802.11 power save - WIFI-TRAFFIC_BUSY
Sep 13 13:17:31 parrot kernel: [  285.853678] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
Sep 13 13:17:31 parrot kernel: [  285.853682] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = ACTIVE, drv ps mode = 0, rlbm = 0 , smart_ps = 0, allQueueUAPSD = 0
Sep 13 13:17:33 parrot kernel: [  287.869631] RTW: rtw_set_ps_mode(wlan0) Enter 802.11 power save - WIFI-TRAFFIC_IDLE
Sep 13 13:17:33 parrot kernel: [  287.869638] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
Sep 13 13:17:33 parrot kernel: [  287.869644] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = LPS, drv ps mode = 2, rlbm = 1 , smart_ps = 2, allQueueUAPSD = 0
Sep 13 13:17:39 parrot kernel: [  293.917609] RTW: rtw_set_ps_mode(wlan0) Leave 802.11 power save - WIFI-TRAFFIC_BUSY
Sep 13 13:17:39 parrot kernel: [  293.917614] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
Sep 13 13:17:39 parrot kernel: [  293.917617] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = ACTIVE, drv ps mode = 0, rlbm = 0 , smart_ps = 0, allQueueUAPSD = 0
Sep 13 13:17:55 parrot kernel: [  310.045637] RTW: rtw_set_ps_mode(wlan0) Enter 802.11 power save - WIFI-TRAFFIC_IDLE
Sep 13 13:17:55 parrot kernel: [  310.045645] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
Sep 13 13:17:55 parrot kernel: [  310.045650] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = LPS, drv ps mode = 2, rlbm = 1 , smart_ps = 2, allQueueUAPSD = 0
Sep 13 13:18:23 parrot kernel: [  338.269632] RTW: rtw_set_ps_mode(wlan0) Leave 802.11 power save - WIFI-TRAFFIC_BUSY
Sep 13 13:18:23 parrot kernel: [  338.269640] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
Sep 13 13:18:23 parrot kernel: [  338.269645] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = ACTIVE, drv ps mode = 0, rlbm = 0 , smart_ps = 0, allQueueUAPSD = 0
Sep 13 13:18:25 parrot kernel: [  340.285644] RTW: rtw_set_ps_mode(wlan0) Enter 802.11 power save - WIFI-TRAFFIC_IDLE
Sep 13 13:18:25 parrot kernel: [  340.285651] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
Sep 13 13:18:25 parrot kernel: [  340.285656] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = LPS, drv ps mode = 2, rlbm = 1 , smart_ps = 2, allQueueUAPSD = 0


dmesg

[   24.209817] RTW: [HW_VAR_BASIC_RATE] 0x150->0x150->0x150
[   24.210296] RTW: rtw_ndev_notifier_call(wlan0) state:4
[   24.210567] RTW: rtw_ndev_notifier_call(wlan0) state:4
[   24.210856] RTW: WMM(0): 0, a42b
[   24.210995] RTW: WMM(1): 0, a44f
[   24.211103] RTW: WMM(2): 0, 5e4322
[   24.211226] RTW: WMM(3): 0, 2f3222
[   24.211234] RTW: wmm_para_seq(0): 0
[   24.211235] RTW: wmm_para_seq(1): 1
[   24.211237] RTW: wmm_para_seq(2): 2
[   24.211238] RTW: wmm_para_seq(3): 3
[   24.211351] RTW: HTOnAssocRsp
[   24.211476] RTW: VHTOnAssocRsp
[   24.214873] RTW: ============ STA [c8:a7:0a:a2:5e:54]  ===================
[   24.214875] RTW: mac_id : 0
[   24.214876] RTW: wireless_mode : 0x44
[   24.214878] RTW: mimo_type : 2
[   24.214880] RTW: bw_mode : 80MHz, ra_bw_mode : 80MHz
[   24.214881] RTW: rate_id : 9
[   24.214884] RTW: rssi : -1 (%), rssi_level : 0
[   24.214886] RTW: is_support_sgi : Y, is_vht_enable : Y
[   24.214888] RTW: disable_ra : N, disable_pt : N
[   24.214889] RTW: is_noisy : N
[   24.214890] RTW: txrx_state : 0
[   24.214892] RTW: curr_tx_rate : CCK_1M (L)
[   24.214893] RTW: curr_tx_bw : 20MHz
[   24.214895] RTW: curr_retry_ratio : 0
[   24.214896] RTW: ra_mask : 0x00000000fffffff0

[   24.215352] RTW: wlan0 wakeup macid=0, ori reg_0x4d4=0x00000000
[   24.216476] RTW: WARN hw_port0_tsf_sync_sel(wlan0): port0 already disable TSF sync
[   24.216484] RTW: hw_var_set_dl_rsvd_page(wlan0):+ hw_port=0 mstatus(1)
[   24.217361] RTW: _rtw_hal_set_fw_rsvd_page PageSize: 128, RsvdPageNUm: 8
[   24.217369] RTW: LocPsPoll: 1
[   24.217376] RTW: LocBTQosNull: 2
[   24.217381] RTW: LocNullData: 3
[   24.217386] RTW: LocQosNull: 4
[   24.217391] RTW: _rtw_hal_set_fw_rsvd_page PageNum(5), pktlen(640)
[   24.217478] RTW: _rtw_hal_set_fw_rsvd_page: Set RSVD page location to Fw ,TotalPacketLen(640), TotalPageNum(5)
[   24.217481] RTW: RsvdPageLoc: ProbeRsp=0 PsPoll=1 Null=3 QoSNull=4 BTNull=2
[   24.218478] RTW: wlan0: DL RSVD page success! DLBcnCount:1, poll:1
[   24.219954] RTW: STA Beamforming Capability=0x04
[   24.219961] RTW: _get_txvector_parameter: BSSID=c8:a7:0a:a2:5e:54
[   24.219964] RTW: _get_txvector_parameter: GROUP_ID=0x00 PARTIAL_AID=0x00a8
[   24.219967] RTW: _bfer_add_entry: Add BFer entry beamformer_su_reg_maping=0x1, su_reg_index=0
[   24.219973] RTW: +rtl8822b_phy_bf_enter: c8:a7:0a:a2:5e:54
[   24.219976] RTW: _config_beamformer_su: Config SU BFer entry HW setting
[   24.220972] RTW: _config_beamformer_su: nc=1 nr=0 group=0 codebookinfo=1 coefficientsize=3
[   24.220974] RTW: _config_beamformer_su: csi=0x0d01
[   24.221094] RTW: -rtl8822b_phy_bf_enter
[   24.221102] RTW: =>mlmeext_joinbss_event_callback - End to Connection without 4-way
[   24.221493] ath: EEPROM regdomain: 0x8348
[   24.221494] ath: EEPROM indicates we should expect a country code
[   24.221496] ath: doing EEPROM country->regdmn map search
[   24.221497] ath: country maps to regdmn code: 0x3a
[   24.221498] ath: Country alpha2 being used: US
[   24.221499] ath: Regpair used: 0x3a
[   24.221501] ath: regdomain 0x8348 dynamically updated by country element
[   24.221512] RTW: _rtw_reg_notifier
[   24.221519] RTW: _rtw_reg_notifier_apply: NL80211_REGDOM_SET_BY_COUNTRY_IE
[   24.221626] RTW: cfg80211_rtw_get_txpower
[   24.221800] RTW: cfg80211_rtw_get_txpower
[   24.225366] RTW: OnAction_back
[   24.225368] RTW: OnAction_back, action=0
[   24.226386] RTW: issue_addba_rsp_wait_ack(wlan0) ra=c8:a7:0a:a2:5e:54 status:=0 tid=0 size:64, acked, 1/3 in 4 ms
[   24.227366] RTW: OnAction_back
[   24.227368] RTW: OnAction_back, action=0
[   24.227392] RTW: recv eapol packet
[   24.227619] RTW: send eapol packet
[   24.229376] RTW: issue_addba_rsp_wait_ack(wlan0) ra=c8:a7:0a:a2:5e:54 status:=0 tid=7 size:64, acked, 1/3 in 0 ms
[   24.241666] RTW: recv eapol packet
[   24.241777] RTW: send eapol packet
[   24.241828] RTW: cfg80211_rtw_add_key(wlan0) adding key for c8:a7:0a:a2:5e:54
[   24.241829] RTW: cfg80211_rtw_add_key(wlan0) cipher=0xfac04
[   24.241830] RTW: cfg80211_rtw_add_key(wlan0) key_len=16, key_index=0
[   24.241831] RTW: cfg80211_rtw_add_key(wlan0) pairwise=1
[   24.241833] RTW: cfg80211_rtw_add_key(wlan0) seq_len:6, seq:0x0
[   24.241834] RTW: rtw_cfg80211_set_encryption
[   24.241835] RTW: rtw_cfg80211_set_encryption(wlan0) set CCMP PTK idx:0, len:16
[   24.241841] RTW: rtw_cfg80211_set_encryption, ret=0
[   24.241855] RTW: cfg80211_rtw_set_default_key(wlan0) key_index=0, unicast=1, multicast=0
[   24.241869] RTW: set pairwise key camid:4, addr:c8:a7:0a:a2:5e:54, kid:0, type:AES
[   24.241910] RTW: cfg80211_rtw_add_key(wlan0) cipher=0xfac04
[   24.241911] RTW: cfg80211_rtw_add_key(wlan0) key_len=16, key_index=1
[   24.241912] RTW: cfg80211_rtw_add_key(wlan0) pairwise=0
[   24.241913] RTW: cfg80211_rtw_add_key(wlan0) seq_len:6, seq:0x29b8
[   24.241913] RTW: rtw_cfg80211_set_encryption
[   24.241914] RTW: rtw_cfg80211_set_encryption(wlan0) set CCMP GTK idx:1, len:16
[   24.241915] RTW: ==> rtw_set_key algorithm(4),keyid(1),key_mask(0)
[   24.241917] RTW: rtw_cfg80211_set_encryption, ret=0
[   24.242012] RTW: cfg80211_rtw_get_txpower
[   24.242283] RTW: cfg80211_rtw_change_station(wlan0) mac:c8:a7:0a:a2:5e:54
[   24.245241] RTW: set group key camid:5, addr:c8:a7:0a:a2:5e:54, kid:1, type:AES
[   24.251996] RTW: rtw_ndev_notifier_call(wlan0) state:4
[   24.523993] vboxdrv: Found 4 processor cores
[   24.545766] vboxdrv: TSC mode is Invariant, tentative frequency 2799998601 Hz
[   24.545768] vboxdrv: Successfully loaded version 6.0.10_Kali (interface 0x00290008)
[   24.548037] Initializing XFRM netlink socket
[   24.558090] VBoxNetFlt: Successfully started.
[   24.568877] VBoxNetAdp: Successfully started.
[   24.579033] VBoxPciLinuxInit
[   24.586160] vboxpci: IOMMU not found (not registered)
[   25.789913] tun: Universal TUN/TAP device driver, 1.6
[   28.341413] RTW: recv eapol packet
[   28.342161] RTW: cfg80211_rtw_add_key(wlan0) cipher=0xfac04
[   28.342164] RTW: cfg80211_rtw_add_key(wlan0) key_len=16, key_index=2
[   28.342166] RTW: cfg80211_rtw_add_key(wlan0) pairwise=0
[   28.342169] RTW: cfg80211_rtw_add_key(wlan0) seq_len:6, seq:0x0
[   28.342170] RTW: rtw_cfg80211_set_encryption
[   28.342173] RTW: rtw_cfg80211_set_encryption(wlan0) set CCMP GTK idx:2, len:16
[   28.342175] RTW: ==> rtw_set_key algorithm(4),keyid(2),key_mask(0)
[   28.342185] RTW: rtw_cfg80211_set_encryption, ret=0
[   28.342204] RTW: set group key camid:6, addr:c8:a7:0a:a2:5e:54, kid:2, type:AES
[   28.342231] RTW: send eapol packet
[   35.869781] RTW: rtw_set_ps_mode(wlan0) Enter 802.11 power save - WIFI-TRAFFIC_IDLE
[   35.869785] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
[   35.869787] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = LPS, drv ps mode = 2, rlbm = 1 , smart_ps = 2, allQueueUAPSD = 0
[   47.415044] RTW: cfg80211_rtw_scan(wlan0)
[   47.415052] RTW: rtw_set_ps_mode(wlan0) Leave 802.11 power save - WIFI-LPS_CTRL_LEAVE
[   47.415056] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
[   47.415058] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = ACTIVE, drv ps mode = 0, rlbm = 0 , smart_ps = 0, allQueueUAPSD = 0
[   47.420471] RTW: [HW_VAR_CHECK_TXBUF] Empty in 4 ms
[   47.420845] RTW: wlan0 sleep m0=0x00000003, ori reg_0x4d4=0x00000000
[   51.784227] RTW: wlan0 wakeup m0=0x00000003, ori reg_0x4d4=0x00000003
[   51.785753] RTW: survey done event(2d) band:0 for wlan0
[   51.785957] RTW: rtw_indicate_scan_done(wlan0)
[   53.201000] RTW: rtw_issue_addbareq_cmd, p=0
[   53.201037] RTW: BA_starting_seqctrl = 204 for TID=0
[   53.201066] RTW: issue_addba_req(wlan0) ra=c8:a7:0a:a2:5e:54 tid=0
[   53.201739] RTW: OnAction_back
[   53.201743] RTW: OnAction_back, action=1
[   53.201745] RTW: agg_enable for TID=0
[   60.061637] RTW: rtw_set_ps_mode(wlan0) Enter 802.11 power save - WIFI-TRAFFIC_IDLE
[   60.061645] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
[   60.061650] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = LPS, drv ps mode = 2, rlbm = 1 , smart_ps = 2, allQueueUAPSD = 0
[   74.173655] RTW: rtw_set_ps_mode(wlan0) Leave 802.11 power save - WIFI-TRAFFIC_BUSY
[   74.173663] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
[   74.173669] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = ACTIVE, drv ps mode = 0, rlbm = 0 , smart_ps = 0, allQueueUAPSD = 0
[   76.189647] RTW: rtw_set_ps_mode(wlan0) Enter 802.11 power save - WIFI-TRAFFIC_IDLE
[   76.189656] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
[   76.189661] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = LPS, drv ps mode = 2, rlbm = 1 , smart_ps = 2, allQueueUAPSD = 0
[   82.237622] RTW: rtw_set_ps_mode(wlan0) Leave 802.11 power save - WIFI-TRAFFIC_BUSY
[   82.237630] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
[   82.237634] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = ACTIVE, drv ps mode = 0, rlbm = 0 , smart_ps = 0, allQueueUAPSD = 0
[   84.253628] RTW: rtw_set_ps_mode(wlan0) Enter 802.11 power save - WIFI-TRAFFIC_IDLE
[   84.253636] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
[   84.253642] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = LPS, drv ps mode = 2, rlbm = 1 , smart_ps = 2, allQueueUAPSD = 0
[   88.285623] RTW: rtw_set_ps_mode(wlan0) Leave 802.11 power save - WIFI-TRAFFIC_BUSY
[   88.285632] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
[   88.285637] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = ACTIVE, drv ps mode = 0, rlbm = 0 , smart_ps = 0, allQueueUAPSD = 0
[   90.301623] RTW: rtw_set_ps_mode(wlan0) Enter 802.11 power save - WIFI-TRAFFIC_IDLE
[   90.301631] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
[   90.301637] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = LPS, drv ps mode = 2, rlbm = 1 , smart_ps = 2, allQueueUAPSD = 0
[   94.333633] RTW: rtw_set_ps_mode(wlan0) Leave 802.11 power save - WIFI-TRAFFIC_BUSY
[   94.333638] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
[   94.333641] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = ACTIVE, drv ps mode = 0, rlbm = 0 , smart_ps = 0, allQueueUAPSD = 0
[   98.365658] RTW: rtw_set_ps_mode(wlan0) Enter 802.11 power save - WIFI-TRAFFIC_IDLE
[   98.365666] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
[   98.365671] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = LPS, drv ps mode = 2, rlbm = 1 , smart_ps = 2, allQueueUAPSD = 0
[  122.557647] RTW: rtw_set_ps_mode(wlan0) Leave 802.11 power save - WIFI-TRAFFIC_BUSY
[  122.557656] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
[  122.557662] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = ACTIVE, drv ps mode = 0, rlbm = 0 , smart_ps = 0, allQueueUAPSD = 0
[  126.589649] RTW: rtw_set_ps_mode(wlan0) Enter 802.11 power save - WIFI-TRAFFIC_IDLE
[  126.589658] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
[  126.589663] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = LPS, drv ps mode = 2, rlbm = 1 , smart_ps = 2, allQueueUAPSD = 0
[  128.605653] RTW: rtw_set_ps_mode(wlan0) Leave 802.11 power save - WIFI-TRAFFIC_BUSY
[  128.605662] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
[  128.605667] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = ACTIVE, drv ps mode = 0, rlbm = 0 , smart_ps = 0, allQueueUAPSD = 0
[  134.653640] RTW: rtw_set_ps_mode(wlan0) Enter 802.11 power save - WIFI-TRAFFIC_IDLE
[  134.653648] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
[  134.653653] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = LPS, drv ps mode = 2, rlbm = 1 , smart_ps = 2, allQueueUAPSD = 0
[  142.717625] RTW: rtw_set_ps_mode(wlan0) Leave 802.11 power save - WIFI-TRAFFIC_BUSY
[  142.717633] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
[  142.717638] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = ACTIVE, drv ps mode = 0, rlbm = 0 , smart_ps = 0, allQueueUAPSD = 0
[  146.749644] RTW: rtw_set_ps_mode(wlan0) Enter 802.11 power save - WIFI-TRAFFIC_IDLE
[  146.749652] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
[  146.749657] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = LPS, drv ps mode = 2, rlbm = 1 , smart_ps = 2, allQueueUAPSD = 0
[  150.781653] RTW: rtw_set_ps_mode(wlan0) Leave 802.11 power save - WIFI-TRAFFIC_BUSY
[  150.781659] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
[  150.781661] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = ACTIVE, drv ps mode = 0, rlbm = 0 , smart_ps = 0, allQueueUAPSD = 0
[  154.813640] RTW: rtw_set_ps_mode(wlan0) Enter 802.11 power save - WIFI-TRAFFIC_IDLE
[  154.813648] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
[  154.813653] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = LPS, drv ps mode = 2, rlbm = 1 , smart_ps = 2, allQueueUAPSD = 0
[  158.845651] RTW: rtw_set_ps_mode(wlan0) Leave 802.11 power save - WIFI-TRAFFIC_BUSY
[  158.845659] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
[  158.845664] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = ACTIVE, drv ps mode = 0, rlbm = 0 , smart_ps = 0, allQueueUAPSD = 0
[  162.877625] RTW: rtw_set_ps_mode(wlan0) Enter 802.11 power save - WIFI-TRAFFIC_IDLE
[  162.877633] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
[  162.877638] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = LPS, drv ps mode = 2, rlbm = 1 , smart_ps = 2, allQueueUAPSD = 0
[  166.909631] RTW: rtw_set_ps_mode(wlan0) Leave 802.11 power save - WIFI-TRAFFIC_BUSY
[  166.909639] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
[  166.909644] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = ACTIVE, drv ps mode = 0, rlbm = 0 , smart_ps = 0, allQueueUAPSD = 0
[  170.941632] RTW: rtw_set_ps_mode(wlan0) Enter 802.11 power save - WIFI-TRAFFIC_IDLE
[  170.941639] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
[  170.941645] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = LPS, drv ps mode = 2, rlbm = 1 , smart_ps = 2, allQueueUAPSD = 0
[  185.057638] RTW: rtw_set_ps_mode(wlan0) Leave 802.11 power save - WIFI-TRAFFIC_BUSY
[  185.057646] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
[  185.057651] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = ACTIVE, drv ps mode = 0, rlbm = 0 , smart_ps = 0, allQueueUAPSD = 0
[  197.149684] RTW: rtw_set_ps_mode(wlan0) Enter 802.11 power save - WIFI-TRAFFIC_IDLE
[  197.149689] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
[  197.149692] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = LPS, drv ps mode = 2, rlbm = 1 , smart_ps = 2, allQueueUAPSD = 0
[  199.165599] RTW: rtw_set_ps_mode(wlan0) Leave 802.11 power save - WIFI-TRAFFIC_BUSY
[  199.165603] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
[  199.165605] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = ACTIVE, drv ps mode = 0, rlbm = 0 , smart_ps = 0, allQueueUAPSD = 0
[  201.181635] RTW: rtw_set_ps_mode(wlan0) Enter 802.11 power save - WIFI-TRAFFIC_IDLE
[  201.181643] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): HW port id=0
[  201.181648] RTW: rtl8822b_set_FwPwrMode_cmd(wlan0): fw ps mode = LPS, drv ps mode = 2, rlbm = 1 , smart_ps = 2, allQueueUAPSD = 0

Ok so I have ruled it out being an issue with Parrot 5.2 because I have tried suspending on Parrot 4.6 and the same issue occurs. Furthermore, I’m not certain if its an issue with the USB adapter because the issue still occurs with it unplugged

I am still having the issue, I have tried many approaches, but none of them have seemed to work. Does anyone have any idea or suggestions as to what I should try next? I really enjoy the OS and suspending a system is a vital tool for me. Any help would be appreciated.

Hi. On the upstream kernel patchwork many things are going on with realtek drivers, I am going to publish a custom linux image so you guys could check if it solves this problem, also it should fix not-working wifi issue which also some users had.

1 Like

thank you Vladyslav! you’re the man!

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.