Troubleshoot Live USB Not Booting Properly/at all

I’m currently troubleshooting something and I need help because I’m starting to give up.

Hardware used: Acer Aspire E 14 E5-471G
Possible Culprits:
motherboard io drivers? xhci handoff?
hardware not supported?
drives? usb flash drive(tried another usb flash drive and using a cd in the cd drive)
usb port? (tried switching between usb 2.0 and 3.0)
video card?
nvidia optimus? (I don’t think so. I tried acpi_osi=! and modprobe.blacklist=nouveau, acpi=off, etc. and no cigar.) Also tried the solutions in arch wiki regarding optimus, bumblebee, etc.

distros tried(live usb):
ubuntu: Tried Xubuntu. Not latest ISO. UEFI. Worked without any hitches.
trisquel works as well
Some say Ubuntu probably has aftermarket fix merged.
parrotos
Test one: Latest ISO. Burned to flash drive. (Note: The tests below with the CD I did with the flash drive beforehand) Made sure dd is successful by comparing /dev/sdX and /parrot.iso. Used USB 2.0 port and Used 3.0 as well in the past. UEFI, Not working.
Test two: Latest ISO. Burned it onto CD. Live without splash and quiet->not working. Started. Green OKs. Shows the Parrot OS ASCII art name and then dvd is still spinning. Goes to a black screen with a black cursor in the middle. Can move for a while then suddenly the cursor hangs. Nothing else happens after.
Test three: Tried Text option after Live. Removed splash and quiet. Booted. Started. Green OKs. Then goes to a black screen with blinking underscore on top left. Nothing else happens after. Tried pressing ctrl + alt + delete. Suddenly kernel displays message again. CD gets ejected. Prompt to remove the live-medium and press enter to continue. Press entered but did not shut down properly as it’s still stuck at the last message of the kernel log. Proceeded to force shutdown.

             Test four: Tried Failsafe (nomodeset) and removed quiet splash from kernel parameters before booting. Booted. Got past ParrotOS ASCII art name and then dvd slowed down spinning. Stuck on screen with kernel log Bluetooth:BNEP socket layer initialized. Blinking underscore on next line. Decided to ctrl alt delete. Same result as above. Suddenly kernel displays message again. CD gets ejected. Prompt to remove the live-medium and press enter to continue. Press enter and it shut down properly.
                
                Test five: Tried Failsafe (disable nvidia/amd gpu), disabled quiet and splash again. Booted. Started. Green OKs. Shows the Parot OS ASCII art name and then dvd still spinning. Goes to a black screen with a black cursor in the middle. Can move for a while then suddenly the cursor hangs. Nothing else happens after. Tried pressing ctrl + alt + delete. Nothing happens. Still stuck. Forced shutdown.
                
                Test six: Tried failsafe strong errors prevention without fiddling with the parameters. Booted. Splash Screen. Hanged.

Parrot Security 4.7 KDE edition amd64 architecture

Used Debian Standard installation method. When using a live usb, doesn’t work (see above). When installed on a drive and when the drive is booted, same results as the live usb.

No multiboot. Parrot and its partitions are the only ones that reside on the drive.

If there are any error messages or relevant logs, post them below:

I have same problem, is the graphic card, I can only use parrot til 4.5

You can try those three Failsafe options, but probably it’s not gonna work too.

You can install Parrot OS 4.5 and change ‘sources.list’ and use normally, updating tools and everything. Use Debian repository in sources.list or install Pentoo, that is another good Pentest Distro, Pentoo even in that newest version is compatible with ours graphic cards.