Tuto install of bumblebee and drivers

Hey everyone,
this tuto has for purpose to show you how to install the Nvidia driver on your system. This tutorial is mainly for those that have two GPUs (so mostly laptop), which are the Intel integrated GPU (Low power consumption) and the Nvidia GPU (high power consumption).

The first thing you want to do is to know whether you prefer to use the nouveau open sourced driver or the nvidia proprietary driver. Make your own research to know the one you prefer and that fit best your needs.

For those that choosed the nouveau driver follow the part 1 of this guide, for the others lets go in part 2.

Part 1: Nouveau

Since the nouveau driver is already integrated to the kernel, there is only one thing to do: Install bumblebee and primus:

sudo apt update && sudo apt install bumblebee primus

To start a programm using the nvidia gpu do this:

optirun yourprogram

And you are done with the install ! To test if the install is successful run this:

optirun glxgears

You might need to reboot to make it work.

Part 2: Nvidia-driver

For those that choosed the proprietary nvidia driver, two extra step are needed.

The first thing to do is to blacklist the nouveau driver, in order to do that, you have to create this file:

sudo nano /etc/modprobe.d/blacklist-nouveau.conf

And write this in the file:

blacklist nouveau
blacklist lbm-nouveau
options nouveau modeset=0
alias nouveau off
alias lbm-nouveau off

When you are done do Ctrl+X and save it.

Then you have to run this to make the changes:

sudo update-initramfs -u

Then reboot.

Now you can install the nvidia driver:

sudo apt update && sudo apt install nvidia-driver

You can install bumblebee and primus:

sudo apt install bumblebee-nvidia primus

To run a program using the nvidia gpu, use optirun:

optirun yourprogram

To test your config, you can run this:

optirun glxgears

A reboot might be needed to make bumblebee work.
And there you are done !

You can contact me for troubleshooting or go on the wiki page of the Bumblebee project:


I had to adjust firejail for optirun and steam to get game running properly. I pretty much just cleared both local profiles for them. Just wanted to add this incase anyone else gets everything going but doesn’t see their gpu properly running things, I don’t remember what my errorline was but that was my solution.

1 Like

Great guide man! Was thinking too about creating something similar, but you came first! :slight_smile:

Worth mentioning, that if you want to enable Tear-free option, you have to:

  1. Create file 20-intel.conf in /usr/share/X11/xorg.conf.d/.
    e.g. touch /usr/share/X11/xorg.conf.d/20-intel.conf

  2. Open with favourite text editor.
    e.g. nano /usr/share/X11/xorg.conf.d/20-intel.conf

  3. Insert next text (and uncomment lines for minor improvements):

     Section "Device"
         Identifier "Intel Graphics"
         Driver "intel"
         #Option "Backlight" "intel_backlight"
         #Option "AccelMethod" "sna"
         Option "TearFree" "true"
         #Option "DRI" "3"
  4. Now, open with your favourite text editor /etc/bumblebee/xorg.nvidia.conf file.
    e.g. nano /etc/bumblebee/xorg.nvidia.conf and in the end of the file append it with following text:

     Section "Screen"
         Identifier "Default Screen"
         Device "DiscreteNvidia"

Now you should have tear-free screen and working bumblebee.
In some guides they say you to edit configs in /etc/X11/xorg.conf.d, but this folder was moved to /usr/share/X11/xorg.conf.d.
However, you still may have some configs there, but be careful with config load priority.


if you install bumblebee-nvidia instead of bumblebee, these steps are done automatically

Okay thanks, i didnt knew that.

There’s also a bug in libglvnd library which is responsible for nvidia graphics drawing, which won’t let you run anything with graphics on your graphics card for REAL.

Workaround is here: Bumblebee XORG

Also to be able to run hashcat and any opengl things you have to instal OpenCL.

sudo apt install -y ocl-icd-libopencl1 nvidia-cuda-toolkit


i did try to install these but i am never able to run hashcat with my gpu. i tried using oprtirun but it always let my gpu undetected

1 Like

try sudo optirun hashcat -I


Using sudo did the trick,great ! thanks