Unable to install Ansible on Parrot 5.3.9-3parrot3

Briefly describe your issue below:

I have tried to install ansible on Parrot 5.3.9-3parrot3 but it doesn’t work.
Firts, I added the following line to /etc/apt/sources.list:
deb http://ppa.launchpad.net/ansible/ansible/ubuntu trusty main

Then, when I run the command " $ sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 93C4A3FD7BB9C367 " I get the error below:

gpg: keyserver receive failed: Server indicated a failure

I have tried any suggestion on the Internet but still not working.

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)

My parrot version is: Kernel Linux 5.4.0-3parrot1-amd64 x86_64

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
I used Debian Standard to install parrot os
Configured to multiboot with other systems? (yes / no)
yes
If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:
$sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 93C4A3FD7BB9C367
Executing: /tmp/apt-key-gpghome.GZFGVOh3w5/gpg.1.sh --keyserver keyserver.ubuntu.com --recv-keys 93C4A3FD7BB9C367
gpg: keyserver receive failed: Server indicated a failure