Unable to locate files Via Caja

Using parrot 4.7. Latest Packages. No Dualboot.

So heres the issue. I have some files of a package that I installed a long time ago. I recollect removing package and deleting leftovers.
Out of curiosity, I was running a bunch of commands and crashed into this thing: I ran a locate <package/file name i deleted/uninstalled/purged> in terminal which i assumed i completely wiped off my device but turns out, there are a bunch of leftovers of that package.

When I tried to delete them, i get error “No such file or directory exists”
Also, i tried to search those files via GUI file manager sudo caja <folderpath> and found nothing in that folder or the folder itself.

Are those cached files that are being shown in terminal? Or am I missing somethin here.
I did clear cache and backups and leftovers using bleachbit [as su and without su] and the when I run locate <filename> the files are still shown.

Curious whatsup with it.
Thanks :slight_smile:

Most likely the files don’t exist.

In short, locate uses a database that isn’t always up to date. In the locate man page it says:

locate reads one or more databases prepared by updatedb (8) and writes file names matching at least one of the PATTERN s to standard output, one per line.

If –regex is not specified, PATTERN s can contain globbing characters. If any PATTERN contains no globbing characters, locate behaves as if the pattern were *** *PATTERN ******** .

By default, locate does not check whether files found in database still exist. locate can never report files created after the most recent update of the relevant database.

If you run updatedb it should update the database for you, then locate wont report the files anymore.

2 Likes

Ahhh! Gotcha! Thanks.
Good Ol’ Saviour @KidKlown :blush:

1 Like

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.