Update Broke Virtualbox Kernel Driver

After i updated the parrot after the OS prompted me to check for updaes, i started getting a bunch of errors. Some fimiliar, few new. One of those new are Virtualbox kernel driver error.

Im unable to run a VM. Have 5 different VM setups, none of them would boot up and all of them would giveout same error as attached below.



It seems like my system has not loaded the Virtualbox kernel during bootup that it usually does.

Tried restarting the device, didnt work. Ran bleachbit, cleared all cache and rest junk, didnt work.

Any sort of help is appretiated.
Thankyou for your attention :slight_smile:

i also have a problem with VMWARE… this also
happened last night when i updated my parrot

it can not compile "virtual machine monitor "

and my english is sorta limited so i had a hard time trying to fix it
but i tried , if i find a solution i will tell you … if anybody else know the solution please
help :slight_smile:

1 Like

Been a couple of days looks like there is no response or help form the Dev team or community.
Thats weird. :thinking:

Please fill out support form found in the support guidelines. It’s a pain to establish a baseline without that info, so you typically won’t get a response without it.

There were some issues when we jumped to the 5.1 Linux kernel, have you upgraded your system in the past 24 hours? My VM setup with virtualbox hasn’t had any issues but without knowing the specifics of your system, it could be several things.

@FriendlyDude Please don’t hijack this topic, VMWare is a completely different product and not something we currently support (we suggest VirtualBox).

I solved the issue thanks to a major Linux irc. Yes i did update my system [when parrot showed me a popup asking for updates]. No im not dual booting and im on Parrot 5.1. Went through a bunch of new community topics and learned devs really did push an update that broke a lot of things. Just curious if they actually test out the updates on a couple of different devices before rolling out the updates.

Anyway, After solving the issue, virtualbox worked fine.

Parrot rolled an update again so i did update, Turns out. It broke the Virtualbox again. Well. Not exactly. But its showing a new error. VM boots up fine but it shows a new error popup that…looks something like this :

Heres a snap of it.


We do indeed. Our Rigorous testing is done by Carl the Sloth, he probably fell asleep halfway through testing.

I think beating Carl at this point for poor quality control counts as animal abuse.


It’s quite clear I think, you’ll have burn the PC, or try reinstalling VboxGuestAdditions.iso

apt search Virtualbox
sudo apt install NAME-OF-PKG

restart Virtualbox
cry tears of joy as it works

Or just cry and come post how it didn’t work and we should die for letting our QA/QC depend on a sloth.

1 Like

You crack me up @s1udge :joy::grin::grin:

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.