Widget disappeared and cant search after update

Briefly describe your issue below:
Hello everyone, so I just updated my OS Parrot on October-6-2019 with the command “sudo Apt full-upgrade” after finishing updating nothing has changed so I immediately turn it off. the next day after I entered the parrot os I realized that the widgets on the taskbar all disappeared except the clock and I also could not search for applications or files in the search bar but I can type it and i also could not right click on the desktop.

Thankyou.

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)
Parrot security kde plasma 4.7

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Via USB installation debian GTK
Configured to multiboot with other systems? (yes / no)
Yes with windows 10
If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

gnome desktop issue, i think the devs are already aware and putting together a patch to fix

Hmmm do you know when patch Will release ?

Thankyou

no clue, haven’t checked the talk in the dev and contributor section yet, they would announce it there first i figure

Can you tell me where i can see the announcement?

Thankyou

Same happened to me hoping, for a fix soon. Before I came here I went to the KDE forums to search for a solution. Ended up deleting my plasma-org etc etc desktop file from ~/.config/…guess I gotta reinstall, just dont feel comfortable about deleting and adding things back. I worry about the integrity of the installation.

Wish I came here first, and glad I still saw this. Otherwise after reinstall I would have had the same problem and died on the inside

Same for me after ‘parrot-upgrade’

<alt + space> Search broken and taskbar lost widgets…

Widgets manually corrected but search (despite everything I’ve tried - loads of .config change and various package re-installs) is still broken…

Also discovered if you drag a widget fromt the taskbar (by mistake in my case) onto the deskop then it’s impossble to remove it and also right click on the desktop seems to have stopped working as well…

not impossible to remove, click the upper right homescreen option click and it should bring up the remove option on the widget you accidentally placed on the home screen

should be under the dev and contributors tab on the top level of the community page

Ah OK. I hope the fix is soon. I had an issue after the update also and made a post but not approved yet.

i think everything that uses gnome desktop had an issue after the update, its not a parrot issue

Hi Guys

Can someone clear somethig up for me please?

Both the OP (Ariq) and leftyf6 have KDE desktops (as do I) not Gnome - this is what drew me to the thread

Just to confirm, I’m on fully up to date rolling Parrot 4.7 and KDE Plasma 5.14.5

It seems we are talking abut a bug in Gnome here, not KDE is rhat right? if so it appears we have similar issues in the KDE desktop…

2 Likes

Hi everyone. We are very sorry about your problems. I’ve create a test machine and I had the problem as well. We can’t not sure this problem is from KDE side, Debian side or our side yet but i’ve found the problem about search


We are very sorry for your issue and thanks for your supports.

2 Likes

it would seem so x.x both KDE and Gnome desktops took a hit this week

Same problem parrot 4.7 kde on a Samsung laptop works like a dream otherwise… I’m just timeshifting until a proper patch comes

No worries and thanks (by return) for your help in resolving it…

Indeed !! hopefully one root cause…

I am installing debian 10 to make sure it is from our side or Debian side (package version problem) or KDE side. It is not fun at all because I watched first EP of Mr.Robot ss4 and the installation is still running and it is midnight here LoL (And the character used older version of firefox-esr LoL)

First information: Debian side still uses KDE Framework 5.54 while we upgraded it to 5.62 (as I remember) so it could be the problem. We have to check if it is bug from KDE side (code bug) or our side (packages and libs version)

How long before you guys approve posts? I submitted hours ago on a fail to fetch error on a certain parrot repo while trying to get around this stuff going on and get a working station.