wifi not recognized (fresh install, laptop)

Briefly describe your issue below:
I got dual-boot, along with Ubuntu 18.04. There are no issues, i mean wifi is working on ubuntu, using iwlwifi driver. However, parrot is not recognize wifi, even if the driver appear to be installed:

$sudo apt search iwlwifi
Sorting… Done
Full Text Search… Done
firmware-iwlwifi/rolling,now 20190717-2 all [installed,automatic]
Binary firmware for Intel Wireless cards
… and this is the output from ifconfig
└──╼ $ifconfig
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.0.60 netmask 255.255.255.0 broadcast 192.168.0.255
inet6 fe80::7da1:8a67:805a:5d15 prefixlen 64 scopeid 0x20
ether f0:d4:e2:f9:48:22 txqueuelen 1000 (Ethernet)
RX packets 18056 bytes 8709644 (8.3 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 8612 bytes 1196379 (1.1 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10
loop txqueuelen 1000 (Local Loopback)
RX packets 3574 bytes 1211604 (1.1 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 3574 bytes 1211604 (1.1 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

… and from iwconfig:

└──╼ $iwconfig
eth0 no wireless extensions.

lo no wireless extensions.

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)

Linux parrot 5.4.0-1parrot1-amd64 #1 SMP Parrot 5.4.6-1parrot1 (2019-12-30) x86_64 GNU/Linux

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)

Configured to multiboot with other systems? (yes / no)

yes, along with Ubuntu 18.04

List your networking hardware (make, model, firmware version):

00:14.3 Network controller: Intel Corporation Wireless-AC 9462

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

need help with that, thank you!

Welcome, justjohndoe :slight_smile:

can you please send the output of:
rfkill

Hi RightToPrivacy, thanks :slight_smile:
This is the output from rfkill:

└──╼ $rfkill
ID TYPE DEVICE SOFT HARD
0 bluetooth hci0 unblocked unblocked

looks like the wifi card does’t appear here… any advice, please?

Maybe should i try the kde version instead?

1 Like