Wireguard-dkms error

Hi,
I am facing issue when I run “sudo parrot-upgrade” command.
The error message are as follows:-

Building initial module for 5.2.0-2parrot1-amd64
Error! Bad return status for module build on kernel: 5.2.0-2parrot1-amd64 (x86_64)
Consult /var/lib/dkms/wireguard/0.0.20191012/build/make.log for more information.
dpkg: error processing package wireguard-dkms (--configure):
 installed wireguard-dkms package post-installation script subprocess returned error exit status 10
Setting up wireguard-tools (0.0.20191012-1) ...
dpkg: dependency problems prevent configuration of wireguard:
 wireguard depends on wireguard-dkms (= 0.0.20191012-1) | wireguard-modules (= 0.0.20191012); however:
  Package wireguard-dkms is not configured yet.
  Package wireguard-modules is not installed.

dpkg: error processing package wireguard (--configure):
 dependency problems - leaving unconfigured
Processing triggers for man-db (2.8.7-3) ...
Errors were encountered while processing:
 wireguard-dkms
 wireguard
Scanning application launchers

Updating active launchers
Done
E: Sub-process /usr/bin/dpkg returned an error code (1)

And the make.log are attached please look into this.

I have tried “sudo dpkg --configure -a” but that would not help.

Please fix this bug/issue.

OS Release Information are as follows:-
No LSB modules are available.
Distributor ID: Parrot
Description: Parrot GNU/Linux 4.7
Release: 4.7
Codename: sid
Linux parrot 5.2.0-2parrot1-amd64 #1 SMP Debian 5.2.9-2parrot1 (2019-08-25) x86_64 GNU/[make.log|attachment](upload://qLjJGEM8Xpz704yUKgmrNSwK24d.log) (2.2 KB)

looks like unmet dependencies at a glance…

└──╼ #apt install wireguard-modules
Reading package lists… Done
Building dependency tree
Reading state information… Done
Package wireguard-modules is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package ‘wireguard-modules’ has no installation candidate

Hi,
Can you tell me how to fix(Resolve dependency or point to the right package).

When I remove wireguard* package then no error came in build up with kernel module.
I think wireguard package have problem form developer side, so look into this when you have time.